Imladris production

Le forum français de création de cartes et de mods pour Bataille pour la Terre du Milieu
 
AccueilFAQRechercherS'enregistrerMembresConnexion

Partagez | 
 

 J'aurais besoin d'aide

Aller en bas 
AuteurMessage
Jeune fou
Débutant(e)
Débutant(e)
avatar

Nombre de messages : 35
Age : 27
Location : France
Add-On : Oui
Date d'inscription : 11/04/2014

MessageSujet: J'aurais besoin d'aide   Sam 27 Sep - 1:16

Bonjour âme charitable qui passe par ici, si tu as un peu de temps libre pour m'aider et si mon problème ne te laisse pas de marbre ça serait génial.

Voici mon problème :

j'ai lu ce tuto http://imladrisproduction.forumotion.com/t1329-commencer-avec-l-ini

Mais quand j'essaie de me rendre dans "playertemplate" (en passant par L'ini extraite (le dossier "data" qui est placé dans mon bureau comme conseillé) pour faire la première étape (interchanger deux héros). Rien que ça ça ne marche pas : lorsque que j'essaie d'ouvrir "playertemplate.ini" avec finalbig ça me met "the file format is unknown. You can still try to open it, but this might not work. Above the type of the file is writtent. If it is similar to "BIGF", there is a chance loading will work. Try to load ?"

Si je réponds "oui", ça me met "out of memory et rien n'apparait. C'est relou et j'aimerais bien qu'on m'aide. Si je n'arrive pas à ne serait que commencer je ne pourrai jamais m'améliorer et j'aimerai bien pourtant. Car je suis sûr qu'on peut faire des choses géniales une fois qu'on peut modder.

Donc oui, je voulais savoir : il faut bien ouvrir le playertemplate qui se trouve dans l'ini qu'on a extraite ("data" sur le bureau ... ce que j'ai fait jusqu'à présent) ? Ou l'ini du jeu dans program files electronic art etc (ce que je n'ai pas fait encore) ... ?

Je jure que je suis bloqué de chez bloqué. Ça fait au moins 20 fois que j'essaie ... et je commence à désespérer.

Merci par avance à tous ceux qui voudront bien m'aider.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Rhaegar
Moddeur confirmé
Moddeur confirmé
avatar

Nombre de messages : 235
Location : Actuellement, quelque part en Westeros
Add-On : Yop !
Date d'inscription : 25/07/2012

MessageSujet: Re: J'aurais besoin d'aide   Sam 27 Sep - 12:04

Salut à toi Jeune fou ^^
Alors pour te répondre vite fait, oui essaye plutôt d'ouvrir le INI.big présent dans program files ect (fait tout de même une sauvegarde de l'INI d'origine avant dans tes documents, on sait jamais). Si ça marche pas viens nous le dire si possible en mettant le message d'erreur (si il y en as)
@+ !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jeune fou
Débutant(e)
Débutant(e)
avatar

Nombre de messages : 35
Age : 27
Location : France
Add-On : Oui
Date d'inscription : 11/04/2014

MessageSujet: J'aurais besoin d'aide   Sam 27 Sep - 14:50

Merci ! à première vue ça a marché : en jouant j'avais bien Gandalf chez les elfes et Legolas chez les hommes.

Je vais pouvoir m'attaquer au reste du tuto maintenant. Merci pour ton aide !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jeune fou
Débutant(e)
Débutant(e)
avatar

Nombre de messages : 35
Age : 27
Location : France
Add-On : Oui
Date d'inscription : 11/04/2014

MessageSujet: J'aurais besoin d'aide   Sam 27 Sep - 17:17

Bon ben nouveau problème : quand je change les codes pour ajouter un bataillon de soldat du gondor (en plus des deux bâtisseurs) comme dans le tuto ça ne marche pas.

Voici les lignes de code. Personnellement je n'y vois pas d'erreur :

";------------- NO STARTING UNITS FOR YOU -------
;StartingUnit0 = GondorFighterHorde
;StartingUnitOffset0 = X:-60 Y:185 Z:0


StartingUnit1 = MenPorter
StartingUnitOffset1 = X:30 Y:200 Z:0

StartingUnit0 = MenPorter
StartingUnitOffset0 = X:1 Y:130 Z:0

StartingUnit2 = GondorFighterHorde
StartingUnitOffset2 = X:30 Y:200 Z:0

StartingUnitTacticalWOTR = MenPorter ;// This unit is placed in tactical mode when playing WOTR. Add multiple lines for multiple units."




Après est ce qu'il faut supprimer " ";------------- NO STARTING UNITS FOR YOU -------
;StartingUnit0 = GondorFighterHorde
;StartingUnitOffset0 = X:-60 Y:185 Z:0"

Qui empêche peut être l'apparition de nouvelles unités (je ne l'ai pas ajouter, c'était déjà là au départ) ?

En tous cas j'ai fait plusieurs tests : j'ai teste avec " StartingUnit2 = GondorFighterHorde
StartingUnitOffset2 = X:30 Y:200 Z:0"

En dessous des bâtisseurs (comme suggéré par le tuto), entre les deux bâtisseurs ET au dessus puis j'ai également teste avec et sans espaces. Mais RIEN ne se passe. Je n'ai que les deux bâtisseurs du début. Ce que j'ai fait pour vérifier s'ils étaient invisible (on sait jamais), j'ai créer un bataillon dans la caserne puis j'ai doublé cliquer dessus pour sélectionner toutes les unités identiques dans le secteur mais il n'y avait rien. Après, peut être qu'il faut que je modifie légèrement les coordonnées d'apparition afin qu'ils ne soient pas au même endroit que les bâtisseurs ? Mais ça me semble bizarre parce quand le mode guerre de l'anneau lorsqu'on a des unités au départ elles se chevauchent sans problème ...

En tous cas si vous savez quoi que se soit pour m'aider ou si vous voyez une erreur n'hésitez pas à me le dire.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Denescor
Moddeur confirmé
Moddeur confirmé
avatar

Nombre de messages : 378
Age : 22
Location : Forodwaith... mais plus pour longtemps
Add-On : oui, ne travaille que sur l'Add-On mais je ne possède pas BFME I
Date d'inscription : 28/05/2013

MessageSujet: Re: J'aurais besoin d'aide   Sam 27 Sep - 17:31

salut Jeune Fou,
Jeune Fou a écrit:
Après est ce qu'il faut supprimer " ";------------- NO STARTING UNITS FOR YOU -------
;StartingUnit0 = GondorFighterHorde
;StartingUnitOffset0 = X:-60 Y:185 Z:0"

Qui empêche peut être l'apparition de nouvelles unités (je ne l'ai pas ajouter, c'était déjà là au départ) ?
ça se voit que tu es débutant Wink
tout les codes précédés d'un ";" sont des commentaires ou des lignes de codes "supprimés", donc non ça n'empêche rien Smile

Essaie de retirer les ";" devant  
Code:
;StartingUnit0 = GondorFighterHorde
;StartingUnitOffset0 = X:-60 Y:185 Z:0
on sait jamais ça peu marché, et dans ce cas ça voudrait dire que toutes nouvelles unités d'un type doit être nommé 0 au début (et non 2 comme tu as fait Wink)

_________________

"Laissez libre cours à votre imagination et innovez..."
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Denescor
Moddeur confirmé
Moddeur confirmé
avatar

Nombre de messages : 378
Age : 22
Location : Forodwaith... mais plus pour longtemps
Add-On : oui, ne travaille que sur l'Add-On mais je ne possède pas BFME I
Date d'inscription : 28/05/2013

MessageSujet: Re: J'aurais besoin d'aide   Sam 27 Sep - 17:44

Sinon j'ai regardé vite fait le tuto et vu que tu l'as suivi à la lettre, soit le tuto est faux (très très très très peu probable ^^), soit tu as oublié un petit détail quelque part Wink

par exemple j'ai vu ça
Tuto ini parti I a écrit:
faites attention car si vous prenez l'INI de bfmII ( bataille pour la terre du milieu II en anglais Battle For the Middle-earth Wink ) votre modification ne sera pas visible avec l'add-on ( l'avenement du roi sorcier, aussi ROTW : Rise Of The Witchking )
ça peu venir de là, si tu modifies pas le bon ini c'est sur que ça va pas marcher Smile

Sinon pour le moment je vois pas, des fois l'ini est capricieux et certains codes qui devraient fonctionner ne font rien...

PS: Pour Gandalf et Legolas il faut peut être préciser dans leurs codes respectifs qu'ils ont changé de camps Wink
il y aura une ligne du style "faction = " dans l'ini des deux héros, sur l'un se sera Men et l'autre Elves, il suffit de les changer (c'est une idée, ça peut ne rien faire du tout, même moi qui fait pleins de choses avec l'ini ce tuto je ne le maîtrise pas entièrement ^^)

_________________

"Laissez libre cours à votre imagination et innovez..."
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jeune fou
Débutant(e)
Débutant(e)
avatar

Nombre de messages : 35
Age : 27
Location : France
Add-On : Oui
Date d'inscription : 11/04/2014

MessageSujet: J'aurais besoin d'aide   Sam 27 Sep - 18:19

Bon ben ça change strictement rien d'enlever les ";". Je ne m'étais pas trompé de répertoire donc ça vient pas de là. Et j'ai changé les 2 en 0 (même si dans le tuto on dit clairement qu'il faut mettre 2) mais ça à rien changé du tout, je me retrouve toujours que avec les bâtisseurs au début. J'ai aussi essayé en changeant la position du code (en le mettant au dessus ET en dessous des bâtisseurs), mais encore une fois rien n'a changé.

Bref ... ça soule il y'a rien qui marche ... et le pire c'est de se dire que ça c'est sensé être la base ... qu'est ce que ça sera quand j'attaquerai les trucs difficiles.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Denescor
Moddeur confirmé
Moddeur confirmé
avatar

Nombre de messages : 378
Age : 22
Location : Forodwaith... mais plus pour longtemps
Add-On : oui, ne travaille que sur l'Add-On mais je ne possède pas BFME I
Date d'inscription : 28/05/2013

MessageSujet: Re: J'aurais besoin d'aide   Sam 27 Sep - 20:17

jeune fou a écrit:
Bref ... ça soule il y'a rien qui marche ... et le pire c'est de se dire que ça c'est sensé être la base ... qu'est ce que ça sera quand j'attaquerai les trucs difficiles.
Des bases... on va dire des bases ++, les vrais bases c'est pas ça, y a plus simple pour commencer et comprendre comment fonctionne vraiment les objets du jeu, genre ici: http://imladrisproduction.forumotion.com/t1-comprendre-et-modifier-un-objet-informations-de-base-sur-le-mapini (c'est ce avec quoi j'ai commencé, j'ai bcp galéré ^^),
http://imladrisproduction.forumotion.com/t536-changer-l-unite-elfe-simple-sur-mallorn (ça c'est sympa aussi Wink)
http://imladrisproduction.forumotion.com/t1662-changer-la-forteresse-de-depart
http://imladrisproduction.forumotion.com/t997-ajout-des-archers-du-rohan (ça peut être bien aussi)
et après dans celui que tu fait, zappe la Ier partie, la suite fonctionnera, car à moins que tu es oublié de sauvegardé ton ini, ça ne rien faire...

la base c'est le CommandSet, les CommandButton, les Modules, la santé, les PC et des notions vagues en weapon, locomotorSet, et specialpower. Le PlayerTemplate ça vient bien après tout ça... Smile.
Jouer avec les factions et l'IA c'est tout de suite d'un autre niveau... quelque soit la manip ^^

Et quand tu feras plus compliqué tu maîtriseras les bases donc tu comprendras pourquoi ça marche pas Wink

_________________

"Laissez libre cours à votre imagination et innovez..."
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Jeune fou
Débutant(e)
Débutant(e)
avatar

Nombre de messages : 35
Age : 27
Location : France
Add-On : Oui
Date d'inscription : 11/04/2014

MessageSujet: J'aurais besoin d'aide   Dim 28 Sep - 21:16

Merci pour tout cela. Je vais prendre mon temps pour bien lire en détail et je tiendrai au courant de mes succès et échecs.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Miraak
Moddeur confirmé
Moddeur confirmé
avatar

Nombre de messages : 304
Age : 17
Location : Lille (France)
Add-On : #TEAM ROTWK
+BFME1
#BFME2 OBSOLETE^^
Date d'inscription : 10/11/2013

MessageSujet: Re: J'aurais besoin d'aide   Mer 29 Oct - 13:01

n'extrait pas l'ini pour le modifier modifie le directement avec final big j'avais les meme problèmes que toit quand j'utiliser l'ini extrait essaye de faire tes modif directement avec final big en ouvrent l'ini non extrait Wink
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: J'aurais besoin d'aide   

Revenir en haut Aller en bas
 
J'aurais besoin d'aide
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Je n'ai pas besoin d'aide... Ok, peut-être juste un peu... [pv Saros]
» BESOIN D'AIDE POUR UN SAUVETAGE DE 21 CHIENS DE CEUTA
» Besoin d'aide pour choisir une base!
» BESOIN D'AIDE POUR LES CHIENS DE ISTRES ( Dépt.13 )
» Besoin d'aide pour une armée de rhun

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Imladris production :: Mods :: Mods-
Sauter vers: